Welcome Guest 

Show/Hide Header

Welcome Guest, posting in this forum requires registration.

Pages: [1]
Author Topic: Software not staying connected
College AU
Posts: 7
Post Software not staying connected
on: May 14, 2017, 10:58

[embed][/embed]Hello Forum Users,
here is one for you.
I am using the latest firmware that Sandy has pointed me to just recently.

the board i am using is the Arduino Mega ADK

The changes to the firmware is as follows

1. Specify what kind of controller board you are using
I specified MEGA
2. Add some libraries if you have a MEGA
I added the libaries
3. Specify what kind of motor driver you are using:
I am using Adafruit Motorshield v1
4. Turn on some debugging code
Left off
5. Disable program features if you need to free up space
I have enough space

SO this is what happens,
When i upload the firmware to my arduino just fine.. no dramas there,
I open the software, again it came with the firmware so the latest version
and go to setup and press serial and connect to COM8, which is my arduino.
the software says, Polargraph ready (Mega) or to that effect.
when i am resizing the board and paper the polargraph remains connected and all is good.
however when i try and position the pen on the software, it instantly disconnects, the GCODE that is being processed is orange where he software originally said that it was ready same happens when i click go to home or any other command that requires moving the pen...

I have tried a few other buttons and "sometimes" it lets me do a couple of commands and then hangs, but most of the time it just tries one and then hangs..

I Have tried the "latest" Firmware on the old software and it works fine. but the reason i want the new software is so that i can use Death to sharpie...

I have tried my UNO also and the same result happens.

I am resorting to using the old software the i found somewhere on Sandy's page.. but i cant seem to find the link where anymore...

Any thoughts people would be great.

cheers everyone

Posts: 1449
Post Re: Software not staying connected
on: May 20, 2017, 17:42

Brilliant report - really clear what's happening here, and the video tells the story excellently, thank you.

One thing wasn't clear though - the serial port disconnection. I can't see this happening in the video. Do you get a notification in windows that the USB has disconnected? How do you know it's disconnected?

The good news is that your main problem is very simple to solve: You need to "set home" before any movement will make any sense. If you don't use "set home" to tell the machine where the pen is, then the machine has a kind of weird "default" position, that is miles off the board in some unlikely direction.

When you click "return to home", it tries to run the motors to move the pen from it's default position (20 foot off in some random direction), towards the home point. This is a long way, and takes a long time, so it looks like it's hung, but in fact it's just working away.

Every time you turn the machine on, or reset it, or reconnect the com port, you need to do a "set home" to re-orientate the machine. OR you can do a "set pen position" if you happen to know exactly where the pen is on the board. ("set home" is the same command as "set pen position", but with a pre-set position.)

The other good news is that you've discovered a genuine bug in the wild 🙂

The controller "knows" from the conversation it has with the machine, what kind of firmware is loaded (UNO, MEGA, Polarshield for instance), and only offers features in that it knows that firmware supports. For instance, if you connect to a UNO based machine, it doesn't offer the option to render spiral or sawtooth based pixels, because it knows that machine can't do them.

So! The bug is that the controller thinks that MEGA based machines can draw sawtooth pixels, when in fact they can't. The messages you see "... not recognised" are exactly that, it doesn't recognise the C15 commands.

Now, there's two solutions to this:

1) Fix the controller so it _doesn't_ offer the opportunity to choose options that don't work. I can do this easily, but the work around is just to not use sawtooth.

2) Enable sawtooth in the firmware. I can't remember why it isn't in there already - but I think it was because sawtooth was simply never very good. Not a very impressive style.

Good luck,

College AU
Posts: 7
Post Re: Software not staying connected
on: May 21, 2017, 11:24

ok so update,
you were right Sandy, When i set the home, then the whole process never stopped. i never got disconnected. and now that you mentioned it, being disconnected actually never happened... it just tooook forever for the code to be cleared and the software to returned to Polargraph ready state.
so when i went to check the connection thats when it was kicked.. 🙂

But now that i home the position it works fantastically..

NOW to wait for my steppers and motor shield to get here so i can test this out on PAPER! 🙂

Thanks for the reply buddy

Pages: [1]
Mingle Forum by cartpauj
Version: 1.0.34 ; Page loaded in: 0.015 seconds.