Forum

Welcome Guest 

Show/Hide Header

Welcome Guest, posting in this forum requires registration.





Pages: [1]
Author Topic: Question on TSP in Polargraph
jsecondo
Newbie
Posts: 9
Permalink
Post Question on TSP in Polargraph
on: December 23, 2017, 01:42
Quote

Hey guys,

My machine finally is drawing. Arduino Mega + ULN2003 + 28y motors + servo.

I'm trying a multipass drawing. I did a color separation from a photograph and passed the 4 components through stipplegen to generate TSP of each of them.

When I load the TSP on the controller and begin drawing, the machine starts to draw each point instead to draw a single line passing through each point.

Is this supposed to work this way? Isn't TSP a single line?

Thanks

kongorilla
Pro
Posts: 387
Permalink
kongorilla
Post Re: Question on TSP in Polargraph
on: December 23, 2017, 06:22
Quote

Yes, the TSP is a single line.

Did you take a look at the SVGs in a program like Inkscape or Illustrator? It sounds like you might've saved stipple files rather than the TSPs (they're different 'save' buttons in StippleGen). When it draws a point, does it do a tiny circle, rather than just a pen drop? (Stipples from StippleGen are circles, not dots).

If you post an SVG somewhere, I'll take a look at it.

A hack solution would be to disconnect your servo while in the 'pen down' position.

jsecondo
Newbie
Posts: 9
Permalink
Post Re: Question on TSP in Polargraph
on: December 23, 2017, 17:22
Quote

My bad. While saving the yellow component (TSP of the yellow image), I pressed on the SAVE STIPPLE instead of SAVE TSP.

My mistake. The rest of the tsp appear just like that....a single line.

Thanks kongorilla.

Pages: [1]
Mingle Forum by cartpauj
Version: 1.0.34 ; Page loaded in: 0.124 seconds.