Forum

Welcome Guest 

Show/Hide Header

Welcome Guest, posting in this forum requires registration.





Pages: [1]
Author Topic: Pen Lift does not work (status: busy)
skimbeh
Newbie
Posts: 2
Permalink
Post Pen Lift does not work (status: busy)
on: February 21, 2020, 15:36
Quote

Hi People,

My servo / pen lift won't work..

I do not use a shield, but big DM860 stepper drivers. For the servo, I have it connected to digital pin 9. Everything works fine when I run the program, but the servo does not work.

When I click 'Pen Lift' or 'Pen Drop' in the controller I hear the USB connecting and disconnecting and the servo itself makes a sound (like it is trying to do something) and then the polargraph controller stays at 'BUSY'.

I'm using an Arduino MEGA and processing 2.2.1.

Does anyone know what is going on?

sandy
Administrator
Posts: 1443
Permalink
sandy
Post Re: Pen Lift does not work (status: busy)
on: February 21, 2020, 18:38
Quote

Sometimes the servo motor can draw so much current and microcontroller gets starved and resets. It's because the servos are often powered from off the 5v that comes over the USB connection, and sometimes that can't supply much current.

Increase the current available to the supply wire of the servo. Depending on how you have it wired up, that might be as simple as plugging in a separate low voltage power supply to the arduino.

sn

skimbeh
Newbie
Posts: 2
Permalink
Post Re: Pen Lift does not work (status: busy)
on: February 24, 2020, 09:15
Quote

Thank you Sandy! I've added an external power supply and it works like a charm 🙂

sandy
Administrator
Posts: 1443
Permalink
sandy
Post Re: Pen Lift does not work (status: busy)
on: February 24, 2020, 09:53
Quote

Ah! Good work!

Sn

Pages: [1]
Mingle Forum by cartpauj
Version: 1.0.34 ; Page loaded in: 0.009 seconds.