Forum

Welcome Guest 

Show/Hide Header

Welcome Guest, posting in this forum requires registration.





Pages: [1]
Author Topic: draw vector gives shakey lines
indignantw-
orld
Newbie
Posts: 5
Permalink
Post draw vector gives shakey lines
on: May 25, 2018, 07:13
Quote

When I get the controller to queue a vector it makes a line that is very wobbley! I have done this on a mac and PC. It means a streight line is made into a series of short lines (slow) and they are not in line with the vector (inaccurate) I have not had this problem before.
I am running an arduino UNO with Big Easy Driver through the latest git hub version of the controller on both MAC and PC (latest OS) and getting strange results. The vector is rendered as many short lines and not at all reflecting the vector. This machine is a few years old and this is a new issue.
Image

Guest

Posts: 7
Permalink
Post Re: draw vector gives shakey lines
on: May 27, 2018, 23:22
Quote

Hello! I've spent most of today revisiting the Polargraph Controller code and have just pushed a couple of changes that might help you. I'll do v2.5.2 release notes later, but here's the short version:

1) There was a bug that switched the polygonizer type every time you started up. This was to do with an esoteric way I'd built of using a toggle button to switch between the two different types: UniformLength and Adaptative. If you had one specified in your properties file, it'd switch to the other one and not really tell you about it. Super annoying and has probably caused a bit of pain here with Polargraphers, so I apologise for taking so long to get around to it.

The kind of picture that you're seeing (above) is when you use "UniformLength". It splits lines up into smaller lines, regardless of whether they need it or not.

Make sure you use Adaptative instead.

2) The vector preview used to snap points to full millimetres. Now it'll use floats instead of ints. This means that the queue preview tends to fit the loaded vector art a little better.

I don't believe this should make any difference to the actual drawing though... Just the way it previews in the controller.

This might have some other consequences that I can't think of right now, because that method is used a lot in the program.

3) The polygonizer type and the density preview style were two buttons that cycled through a series of options, and they both had the issue (1) above. That explains why those settings were never set to what I expected...

I'm using a kind of drop-down in those places instead, that drops down a little scrollable list box that you can scroll with the mousewheel. I've never used this kind of control before, so keen to see if it'll work. I might also use it for serial port lookup.

4) I've re-ordered a few buttons, grouping the vector art ones, and the bitmap ones together. This looks a bit more untidy, but makes more sense in my head. More things are now disabled when a vector or bitmap isn't loaded.

Have a shot and see if that makes any improvement to you!

sn

indignantw-
orld
Newbie
Posts: 5
Permalink
Post Re: draw vector gives shakey lines
on: May 29, 2018, 00:10
Quote

Thanks that has solved the problem! your speed and proficiency is truely appreciated!

sandy
Administrator
Posts: 1308
Permalink
sandy
Post Re: draw vector gives shakey lines
on: May 29, 2018, 22:21
Quote

Ah - really great to hear that it worked ok for you!

Pages: [1]
Mingle Forum by cartpauj
Version: 1.0.34 ; Page loaded in: 0.023 seconds.