Forum

Welcome Guest 

Show/Hide Header

Welcome Guest, posting in this forum requires registration.





Pages: [1]
Author Topic: Controller refuses to lift pen over masked pixels
Guest
Newbie
Posts: 7
Permalink
Post Controller refuses to lift pen over masked pixels
on: January 4, 2017, 15:36
Quote

Hi all! Just reinstalled Windows, installed all stuff and Java and started to play with Polargraph but this problem appeared=( Then I click "render pixels" with settings like on screenshot or anything else controlled generates commands then it drops pen and starts drawing all the way instead of drawing just needed pixels without blank spase. It generates only one command to servo - C13 to drop the pen. I inspected all queue for it.
I tried to do it with 3 different versions of controller - precompiled, downliaded from Github and one that downloads with arduino firmware in one archive. What's the problem it is an how can I resolve it?
P.S. Vectors working good.
Image

kongorilla
Pro
Posts: 384
Permalink
kongorilla
Post Re: Controller refuses to lift pen over masked pixels
on: January 4, 2017, 21:53
Quote

You have the "BRIGHT PIXEL" parameter at 255 (which is 100% white). Perhaps the pixels in your source image aren't true white? Or perhaps, in general, one needs the value to be below 255 for masking to kick in? (I doubt it, but don't remember offhand and can't check now).

sandy
Administrator
Posts: 1408
Permalink
sandy
Post Re: Controller refuses to lift pen over masked pixels
on: January 4, 2017, 22:56
Quote

Yikes, honestly, masking is one of the worst features of the polargraph controller - such a kludge and not documented anywhere, I'm embarrassed.

Right, how it works: it's really meant to be used as a kind of "chroma key" mechanism for blanking out arbitrary shapes. I used it for making multi layered drawings like https://www.flickr.com/photos/euphy/6121848332/in/album-72157626497662024/. I made my background an unusual colour (#00FF00 is the default - bright green), and then use the "choose mask colour" button and click on any pixel in your picture that is that colour. Nothing appears to happen.

It's really difficult to see if you've got the right colour unless you use something really different to the rest of your image. There is a little information panel you can pop up with "ctrl+i" which has the masking colour at the bottom (calls it chroma-key colour), or you can set it manually in the default.properties.txt file with the controller.pixel.mask.color property.

If you've got your density preview on, then you can click around and you'll see some of the pixels disappear when they get masked out.

Sorry this is such a dog. Kong is right that you might be able to use the "brightest pixel" filter to get it to lift the pen over the white pixels too. Additional warning: This is implemented in a demented way too (if I remember rightly), but I think it does do the same kind of job. I think both approaches (masking or bright pixel filtering) will only lift over pixels at the ends of a row of pixels. I can't remember if there's a built-in way of lifting over blank/masked pixels inside a shape. What I mean is that you can lift over the pixels around the edge of your stag, but probably not the pixels inside your stag - even if they are masked/filtered.

That's a blast from the past, happy new year!

Sandy Noble

Guest
Newbie
Posts: 7
Permalink
Post Re: Controller refuses to lift pen over masked pixels
on: January 5, 2017, 09:14
Quote

Thank you kongorilla and Sandy! You are awesome guys! I used all advises and it works good now. Background of my image was true white but I deleted it in editor and saved jpg for generating new background and it worked. And I used "chroma key" and it works too.
Thanks for ctrl+i feature) I didn't knew about it and I suppose it's not only feature of Polargraph controller. Maybe somewhere exists a list of options?

Pages: [1]
Mingle Forum by cartpauj
Version: 1.0.34 ; Page loaded in: 0.033 seconds.