Forum

Welcome Guest 

Show/Hide Header

Welcome Guest, posting in this forum requires registration.





Pages: [1]
Author Topic: Cant test pen widths
skaia413
Newbie
Posts: 1
Permalink
Post Cant test pen widths
on: March 5, 2017, 00:43
Quote

Hi all!

Built a polargraph using an Arduino Uno R3 copy, ULN2003 drivers connected to 28byj-48 stepper motors using the latest firmware and controller compiled on Processing. My machine is 700mm x 600mm, the drawing surface is 550mm x 430mm using two sheets of what I think is long legal paper lying around. It works with moving the pen to points, I fixed the mm per rev because I am using 1 inch water bottle tops and fishing line for the spool and line. The machine can draw spirals since I previously uploaded code to the board not from the controller to make spirals. The motors move in the right directions.

However, whenever I try to run a pen test in any increments, using various grid sizes, the queue just spits back to me "You probably won't get any detail from this". I tried running images through the controller as well, with the same error message appearing in the first few lines and nothing being drawn. What settings should I put to at least get a successful pen test?

sandy
Administrator
Posts: 1408
Permalink
sandy
Post Re: Cant test pen widths
on: March 5, 2017, 09:34
Quote

Hi - thanks for your detailed description, really helpful.

The warning that the machine sends back is just a warning, it _will_ still attempt to draw the pixel, so it doesn't indicate that the command has been ignored or cancelled.

If the problem is that the pen isn't moving at all during width tests AND "render pixels", then I'd guess that it's not homed, or the motors aren't powered. You do still need to "set home" before you do any movements, to set the position, and to energise the motor coils (lock them). I've never used the ULN2003 drivers, so I don't know how they get energised.

You say that the machine works with moving the pen to points - you mean using the current firmware, you can do a "set home", followed by a series of "move pen to point" and "move direct" and it'll go there? That's a good sign.

Ignoring the fact that the width test doesn't move the pen at all, the way to "fix" the problem of having no detail is to increase the grid size and decrease the pen size. There's a page about it on the wiki that might be useful:

https://github.com/euphy/polargraph/wiki/Empty-pixels and http://www.polargraph.co.uk/2014/08/feedback-in-the-controller/

Pages: [1]
Mingle Forum by cartpauj
Version: 1.0.34 ; Page loaded in: 0.047 seconds.