Forum

Welcome Guest 

Show/Hide Header

Welcome Guest, posting in this forum requires registration.





Pages: [1]
Author Topic: cant draw from svg or traced vector imige
bejfest
Newbie
Posts: 2
Permalink
Post cant draw from svg or traced vector imige
on: April 11, 2017, 19:41
Quote

Hello everyone !
my first post here so be gantle

im pretty new to the topic of drawing devices... soooo i bought complete machine from Sandy and went stright to drawing (of course after reading how this "thing" even works). i probably made some novice mistakes but if its possible pls guide me to the right path

my problem:

first of all my program polargraph crashes... like a lot. could u tell me any way to cofigurate it on processing or elsewhere so it would run as smothly as i saw on Sandys videos ?

second thing is that i cant really draw vectors. they either cant by traced or drawn or if finally program generates path, when pluged in with txt on sd card its just not drawing. it stands in place and just jumpi on servo lift and down pen mechanism for a few minutes as if motor moves werent there. when i render pixel (when i finally manage to with crashing program) it runs smothly so i think the problem is not in the machine or wrong connections.

anyone know possible solutions ?

bejfest
Newbie
Posts: 2
Permalink
Post Re: cant draw from svg or traced vector imige
on: April 11, 2017, 19:44
Quote

ow and last thing i tried using directly prepared svg file and same thing happend just jumping on servo in place 🙂

sandy
Administrator
Posts: 1408
Permalink
sandy
Post Re: cant draw from svg or traced vector imige
on: April 11, 2017, 21:16
Quote

Hi! Happy you got this far 🙂

If your machine is working fine with pixels, but not with vectors, it usually means the machine spec hasn't been set up properly OR ... the home point is not being set.

When it does the "up down up down up down ... " in place, what is normally happening is that it is trying to draw lines, but it's decided that the line is not on the page somehow. What this usually means is that you haven't told the machine where the pen is, so it thinks the pen is off the side somewhere.

You can check this by connecting the arduino serial monitor (or by opening the console in Polargraph controller with ctrl+c), and seeing what message the machine is sending back. I bet it'll be saying "line is not on the page, skipping it".

So, make sure you "send machine spec" after setting up the Polargraph controller.

After that, make sure you always do "set home" as the first command in any drawing session.

Good luck!

Pages: [1]
Mingle Forum by cartpauj
Version: 1.0.34 ; Page loaded in: 0.018 seconds.