Forum

Welcome Guest 

Show/Hide Header

Welcome Guest, posting in this forum requires registration.





Pages: [1]
Author Topic: Problem compiling polargraph_server_polarshield
Millka
Newbie
Posts: 3
Permalink
Post Problem compiling polargraph_server_polarshield
on: April 9, 2018, 23:04
Quote

Hi, thank you for this open source project, its very cool ๐Ÿ˜Ž ๐Ÿ˜‰
I'm using:
arduino mega 2560 r3, ramps 1.4, A4498 Drivers and Nema 17HS8401 motors and Arduino IDE 1.8.5.
trying compile polargraph_server_polarshield, but dont compile with errors:

Arduino: 1.8.5 (Windows Store 1.8.10.0) (Windows 10), ะŸะปะฐั‚ะฐ:"Arduino/Genuino Mega or Mega 2560, ATmega2560 (Mega 2560)"

polargraph_server_polarshield:184: error: 'multiplier' was not declared in this scope

polargraph_server_polarshield:185: error: 'multiplier' was not declared in this scope

exit status 1
'multiplier' was not declared in this scope

Help pls ๐Ÿ™

Millka
Newbie
Posts: 3
Permalink
Post Re: Problem compiling polargraph_server_polarshield
on: April 11, 2018, 21:11
Quote

Code compile on Arduino IDE version 1.6.5, I happy :D:D:D

for compile polargraph_server_polarshield need edit :

// for working out CRCs
const uint32_t PROGMEM crc_table[16] = {
    0x00000000, 0x1db71064, 0x3b6e20c8, 0x26d930ac,
    0x76dc4190, 0x6b6b51f4, 0x4db26158, 0x5005713c,
    0xedb88320, 0xf00f9344, 0xd6d6a3e8, 0xcb61b38c,
    0x9b64c2b0, 0x86d3d2d4, 0xa00ae278, 0xbdbdf21c
};

and use old version Ardiuno IDE

sandy
Administrator
Posts: 1300
Permalink
sandy
Post Re: Problem compiling polargraph_server_polarshield
on: April 11, 2018, 22:13
Quote

Hello, glad you got it working, but the *_polarshield firmware doesn't have this segment of code in it anymore: hasn't been there for years! I think you have an old version.

Also remember that code is for the Polarshield, you'll have to modify it for anything else. The standard polargraph_server_a1 firmware has options to run on RAMPS, perhaps that's what you meant to use?

Sn

Millka
Newbie
Posts: 3
Permalink
Post Re: Problem compiling polargraph_server_polarshield
on: April 13, 2018, 19:40
Quote

oh ๐Ÿ˜€ yes mb i need polargraph_server_a1, i'm search info and read for RAMPS need use polargraph_server_polarshield =| ty for information me, tomorrow i'm update my Polargraph)

Pages: [1]
Mingle Forum by cartpauj
Version: 1.0.34 ; Page loaded in: 0.017 seconds.